Run your Ubuntu/Debian 64 bit system with the latest stable kernel – 4.9!

linuxI have compiled yet another Ubuntu/Debian kernel for 64 bit systems. This time kernel 4.9.0-11-exton, equivalent to Kernel.org’s latest stable kernel 4.9 released 161211.

What’s new in Linux kernel 4.9?

Install kernel 4.9.0-11-exton in Ubuntu/Debian based distributions
My self-compiled Ubuntu kernels can be used in all types of modern Ubuntu systems, including Mint. They can even be used in Debian Jessie (Debian 8.6) and Debian Stretch (upcoming Debian 9). If you want to use my kernel 4.9.0-11-exton for 64 bit systems, you can DOWNLOAD it from here.

md5sum for ubuntu-kernel-64bit-4.9.0-11-exton.zip which is of 71,5 MB.

Installation instructions
Open the zip-file with WinZip, WinRAR or 7-Zip. Or run this command: unzip ubuntu-kernel-64bit-4.9.0-11-exton.zip. Go into the folder ubuntu-kernel-64bit-4.9.0-11-exton and run this command:
sudo dpkg -i *.deb

Then: Run command sudo update-grub (if you use Grub2).

Nvidia
It is possible to install Nvidia’s proprietary drivers if you use “my” kernel 4.9.0-11-exton. Could be useful if you like to play games. The Nvidia drivers in for example Ubuntu’s repositories – “Current” etc. – can’t be used. It is supposed to be “impossible” to install Nvidia’s latest drivers when running kernel 4.8 – 4.9 without “patches” etc. On the other hand it’s a fact that kernel 4.9 has better support for the open-source Nvidia driver Nouveau than any other older kernel.

A small clarification
“My” kernel 4.9.0-11-exton is compiled (almost) the same way as all official Ubuntu kernels. That is, The Ubuntu Way. If not, the kernel would not function in a Ubuntu/Debian system.

Good luck!

2 thoughts on “Run your Ubuntu/Debian 64 bit system with the latest stable kernel – 4.9!”

  1. dpkg: dependency problems prevent configuration of linux-tools-4.9.0-11:
    linux-tools-4.9.0-11 depends on libunwind8; however:
    Package libunwind8 is not installed.
    linux-tools-4.9.0-11 depends on linux-tools-common; however:
    Package linux-tools-common is not installed.

    dpkg: error processing package linux-tools-4.9.0-11 (–install):
    dependency problems – leaving unconfigured
    dpkg: dependency problems prevent configuration of linux-tools-4.9.0-11-exton:
    linux-tools-4.9.0-11-exton depends on linux-tools-4.9.0-11; however:
    Package linux-tools-4.9.0-11 is not configured yet.

    dpkg: error processing package linux-tools-4.9.0-11-exton (–install):
    dependency problems – leaving unconfigured
    Setting up linux-cloud-tools-4.9.0-11 (4.9.0-11.12) …
    Setting up linux-cloud-tools-4.9.0-11-exton (4.9.0-11.12) …
    Processing triggers for man-db (2.7.5-2) …
    Errors were encountered while processing:
    linux-tools-common_4.9.0-11.12_all.deb
    linux-tools-4.9.0-11
    linux-tools-4.9.0-11-exton

    —-
    Tested of course with -f install:
    apt-get -f install
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Correcting dependencies… Done
    The following packages were automatically installed and are no longer required:
    iproute linux-image-4.7.0-1-amd64
    Use ‘apt autoremove’ to remove them.
    The following packages will be REMOVED:
    linux-tools-4.9.0-11 linux-tools-4.9.0-11-exton
    0 upgraded, 0 newly installed, 2 to remove and 40 not upgraded.
    2 not fully installed or removed.
    After this operation, 3,030 kB disk space will be freed.
    Do you want to continue? [Y/n]

    ————–

    What are in these tools? The kernel and headers install just fine, but these tools where a different story.
    Did this on Debian Stretch 64bit, fresh install since a week or so.

    -Helge

Leave a Reply

Your email address will not be published. Required fields are marked *

Solve : *
25 + 3 =